How to: Recover Dashboard Stickies from Mac Time Machine

Have you ever done a clean installation of your Mac OS? Have you ever wanted to do one? Have you ever wanted to have your stickies back on your dashboard without having to recover the entire backup? Here's how to recover dashboard stickies from time machine backup.

Recover Dashboard Stickies

All you need to do is to go to this address on your Time Machine backup:

 ~/Users/YourUser /Library/Preferences/ 


And restore these files (simply copy/paste and replace):  and 


There! Restart your Mac and you’ll have your stickies back in no time!

Finding the Library folder

By the way, I know, finding Library folder could be a bit tricky. So here’s how to do it:

On the Menu Bar in Finder, Library folder will show up if you hold down Alt (Option) key.

 Finder ▹ Go [Hold down Alt (Option) key]  Library 

My Story

Well, this has happened to me more than once! And this little trick has come handy both times as I usually have a lot of info on my dashboard stickies! And I think everybody does. It’s just because they’re always there for quick notes!

Anyways, after doing a clean installation of OS X Mavericks (or Yosemite… or more recently, El Capitan; or even more recently, MacOS Sierra) about a week ago, today, I needed my stickies back! I had an account login on one of them (talk about security and privacy! Right!? lol ) And I didn’t want a full backup restoration. It felt like “what’s the point of a clean installation if I put everything back in it!?” Although it is not really the case!

And I thought, I’ve needed to recover dashboard stickies a couple of times, I might need to again! So I wrote it down for myself. Then I thought “Alright, don’t be selfish! What’s your blog for!?” So it became this post.

Recover dashboard Stickies from Time Machine Backup on MacOS Sierra. Click To Tweet

Hope it helps you as much as it helped me! Let me know in the comments.


Update 1:

It works for OS X Yosemite as well.

Update 2:

And again, it works for OS X El Capitan just fine too.

Update 3:

The trick still works, even though it’s called MacOS Sierra now.

Update 4:

You guessed it right! You can recover dashboard stickies on MacOS High Sierra as well.

52 Comments How to: Recover Dashboard Stickies from Mac Time Machine

  1. Theo April 26, 2014 at 9:59 pm

    OH MY GOD! Thank you!
    You just made my day!
    Thought I’d lost my stickies and all my notes! But everything’s back now!
    Thanks a bunch!

    1. Behrouz April 26, 2014 at 10:16 pm

      You’re very welcome. Glad I could help! 🙂

  2. Mamad April 28, 2014 at 12:01 am

    Thanks, huge help! me and all my mac stuff… you know 🙂 😀

    1. Behrouz April 28, 2014 at 2:23 pm

      You’re welcome 😀

  3. Corey July 26, 2014 at 11:03 pm

    This is incomplete. If you’ve lost most/all of your preference files (which I somehow did during a restore) you also need to copy over: from the same directory.

    1. kalc October 25, 2014 at 10:12 am

      Thanks Corey & Behrouz, it worked. I had done a restore of my machine from time capsule , but for some reason the stickies were missing. After copying the dashboard & widget files, its completely recovered now.

    2. Abhijeet Shegokar January 23, 2017 at 2:55 am

      Thanks Corey and Behrouz!!! Its immense help!!!

  4. Ditte October 21, 2014 at 3:23 pm

    Hi behrouz,
    I’m having difficulties with recovering my dashboard stickies, I hope you can help me somehow?
    I want to recover the stickies from my external hard drive and not from Time machine, which is a problem because I can’t find the Library folder on the external hard drive. When I press Finder – Go – Alt – Library on the external hard drive (of course in a folder from the date when all my stickies were still there), it shows only the files that I already have now and not files from before.

    If you have an explanation or any kind of help at all I would very much appreciate it! thanks.

    1. Behrouz Jafarnezhad October 21, 2014 at 5:52 pm

      Hi Ditte,
      I’m not sure if I get your problem. Let’s go step by step.
      Is it a TimeMachine Backup or not (on your external hard drive)?

      1. Ditte October 22, 2014 at 9:07 am

        – its a backup from my external hard drive
        (its not possible for me to find the specific date on Time Machine, I don’t know why… but it should be possible to do the recovery from an external hard drive as well, right?)

        1. Behrouz Jafarnezhad October 22, 2014 at 10:04 am

          Yes, it’s possible, if you’ve saved all the folders.
          If you can’t find the date you want, try to go to the ‘Latest’ folder if you have it.
          If not, email me ([email protected]) a screenshot of the backup you have, and we’ll take it from there.

  5. Jörn November 29, 2014 at 8:52 pm

    Mate…you saved my day…thats an awesome post! Thanks from cologne!

  6. Cyke December 1, 2014 at 11:27 am

    Hello there ! You’re a real help, but…. I recently did a clean install of my MBP, with yosemite and all, but lost the stickies..
    I followed what you said, and it brought back the stickies, all of them, in their previous position. But they all are blanks. No text in it… Any ideas ?
    thanks 😉

    1. Behrouz Jafarnezhad December 1, 2014 at 7:07 pm

      Hi Cyke,
      That’s weird!
      Try opening the plist files with Textedit, and search for your a piece of your data if you remember any part of it to make sure it’s stored in files. Hopefully, you’ll find something. Let me know how it goes.

  7. amanda March 8, 2015 at 10:09 am


    I have a backup on an external hard drive, I have a “latest” folder but can not seem to find the those files listed.

  8. Solange March 8, 2015 at 10:57 am

    I have a back up from time machine using an external hard drive and I can not find any of the files you have listed. Am I doing something wrong?

      1. Mariana March 11, 2015 at 9:37 pm

        I have the same problem and have no Library folder under my username! Only the normal “system” library… which doesn’t countain any of those files either…

        1. Behrouz Jafarnezhad March 11, 2015 at 10:09 pm

          Have you tried using the “Go” menu? You have two options. Open “your username” folder, then:
          1. Press Cmd+Shift+G then in the box that opens type ‘library’
          2. Click on the Go menu on the top bar, then when you hold Alt (Option) key down, the library option appears in the menu.

  9. Justine May 10, 2015 at 4:36 pm

    Thanks for all the useful info. I found the files in the ‘ghostly’ Library folder on my Time Machine but when I replace them on my current hard drive, it doesn’t work! Maybe I’m pasting them to the wrong place? Just in case, also replaced the as suggested by ‘Cory’.
    Time Machine path:

    Current Mac hard drive path:

    I’ve done ‘Go To’ search but there doesn’t seem to be any other Library folders, even ghostly ones, on current hard drive.
    Hope you can help!

    1. Behrouz Jafarnezhad May 10, 2015 at 4:41 pm

      Hey Justine, the target folder is NOT HDD>Library>Preferences

      It’s HDD>USERS>[Your Username]>Library>Preferences – and it’s probably ghostly too 🙂

      1. Justine May 10, 2015 at 5:46 pm

        Thanks for reply. I searched for Library in both “Users” and “apple” but it said ‘can’t be found’. Pic of path below.

        1. Behrouz Jafarnezhad May 10, 2015 at 6:38 pm

          1. Go to your ‘apple’ folder (that’s the home folder), not the ‘admin’ folder
          2. Change the view to ‘view as icons’ (to make sure your in the right folder)

          3. Press Command + Shift + G then type Library
          3. in the top menu bar click GO and the hold down Alt (Option) key, then the Library appears
          3. Press Command + J and then in the View Option Menu, tick the ‘Show Library Folder’

          You can’t not have the library folder 😀

          1. Justine May 10, 2015 at 7:01 pm

            I found the Library (only method 3. holding down Alt, worked) but to no avail! I copy/pasted/replaced the two files and the widgets and restarted mac but nothing there.Many thanks for trying. Justine

          2. Behrouz Jafarnezhad May 10, 2015 at 7:22 pm

            That’s weird! If I were you, I would’ve tried copying files (including the ones Cory mentioned) from another folder in my backup – not the latest. Worth a shot! And you’re very welcome 🙂

          3. Justine May 10, 2015 at 9:01 pm

            It worked! I also replaced the Stickies Database, so I’m not sure which bit of all that made the difference.
            Thanks so much, you’re a star!

          4. Behrouz Jafarnezhad May 10, 2015 at 9:30 pm

            Awesome! You’re very welcome. Glad I could help 🙂

  10. osman June 25, 2015 at 11:33 pm

    thank you very much…

  11. Maxmundus October 7, 2015 at 9:21 pm

    Thank you soooooo much!! This is really helpful!

    1. Behrouz October 7, 2015 at 9:31 pm

      You’re very welcome. Glad I could help 🙂

  12. Brendan October 19, 2015 at 12:43 am

    I had the same problem after updating to El Capitan. After struggling to find things from my time capsule, I just typed ‘dashboard’ into finder and lo and behold, the dashboard reappeared with all stickies intact.

    1. Behrouz October 19, 2015 at 12:53 am

      That’s pretty cool! Did you do a clean installation or just simple installation?

  13. Lærke May 8, 2016 at 8:26 am

    I ran into this problem today. But i simply can’t find any of the described -plist files… 🙁

    1. Behrouz May 8, 2016 at 9:22 pm

      That’s weird!
      Are you sure you found the right folder?

      1. Claas October 24, 2016 at 11:53 am

        Hey there!
        I have the same problem, too. I can’t find “” and “” in the library in my backup folders…
        The TM backup was in snow leopard, is it possible, that the files had other names these days?

        Thank you so much for your help!!!

        1. Behrouz Jafarnezhad October 26, 2016 at 1:33 am

          Hey, Claas!

          I’m sorry, but as far as I know, the names are the same in Snow Leopard as well.

  14. Joanne September 18, 2016 at 9:32 am

    I have a backup on my external hardrive and I located/replaced the files you and Cory suggested, but it’s still not working for me. :/ not sure what the issue is.

  15. Brian Levi October 9, 2016 at 9:13 pm

    Followed your directions, the widgets / stickies were there, but there was no writing on the notes…Trying to figure it out now but maybe you have some ideas? Thanks!

    1. Behrouz Jafarnezhad October 11, 2016 at 8:39 am

      Hey Brian,

      Make sure you’re in this folder in your backup: ~/Users/YourUser /Library/Preferences/

      Then copy all the .plist files and paste them into the same folder on your current hard drive.

  16. Maddy February 14, 2017 at 9:56 pm


    I cannot seem to find that file name in my library at all on any of my backups. Do you know what’s wrong? Can’t figure it out at all 🙁


    1. Behrouz Jafarnezhad February 14, 2017 at 10:19 pm

      Hey Maddy, are you sure you’re in the right ‘Library’ folder? from the Time Machine backup?

      1. Maddy February 17, 2017 at 11:29 pm

        Yes, I am pretty sure, I have my library folder as a physical folder in my backup. I put it there a while back.

        1. Maddy February 19, 2017 at 9:52 pm

          Please let me know! I had to wipe my hard drive a week ago but I want to see if I can get my stickies back. Thanks!

          1. Behrouz Jafarnezhad February 19, 2017 at 9:56 pm

            If you have the .plist files, you can; otherwise, I’m afraid it’s not possible (to best of my knowledge).

          2. Maddy March 3, 2017 at 6:48 am

            How do I find the the .plist files? I can’t search that – nothing comes up..

          3. Behrouz Jafarnezhad March 3, 2017 at 8:07 am

            I’m sorry, Maddy, but if they’re not in that folder, I’m not sure where you can find them.

  17. Bill November 29, 2017 at 9:10 pm

    DUUUUUUDE…thank you.


Leave A Comment

Your email address will not be published. Required fields are marked *